System.Web.Mail FAQ

Complete FAQ Listing


4.3.9 The transport failed to connect to the server. Printer Friendly   Email This FAQ   Discuss

This is a network related error. Your application cannot connect to the mail server specified
SmtpMail.SmtpServer
  • Is a valid SMTP Server
  • Check to be sure the server System.Web.Mail is executing on can connect to the mail server. Some times firewalls or proxy servers can get in the way.
  • Try specifying the value by IP address. Poor DNS resolution can sometimes hinder name lookups.
  • Make sure the that the mail server is running at port 25
  • .
  • If you did not specify a SmtpMail.SmtpServer property, or if SmtpMail.SmtpServer points to "localhost" (or the equivalent), be sure the SMTP Service is running on port 25.
  • For testing purposes change the MailMessage.From and MailMessage.To properties to an address that exists on SmtpMail.SmtpServer. Some times this exception is thrown, when it really is a relay issue.

 

Discuss This FAQ Item
Got a question? Another Suggestion? Want to post your solution? Discuss it below.
New Post
  • SMTP - Transport failed to connect to the server    [ Reply ]
  • ASPNET user credentials    [ Reply ]
  • The transport failed to connect to the server.    [ Reply ]
  • tRansport Failed    [ Reply ]
    • RE: tRansport Failed    [ Reply ]
  • smtpmail.smtpserver    [ Reply ]
  • Watch out for Viruscan!    [ Reply ]
    • RE: Watch out for Viruscan!    [ Reply ]
  • Mass emailing ..Connection lost error    [ Reply ]
    • RE: Mass emailing ..Connection lost error    [ Reply ]
  • Watch Out For Virus Scanner...This was my problem!    [ Reply ]
  • MailMessage and ViruScan problem    [ Reply ]
  • The transport has lost connection to the server    [ Reply ]
  • I fixed this problem finally...    [ Reply ]
    • RE: I fixed this problem finally...    [ Reply ]
      • RE RE: I fixed this problem finally...    [ Reply ]
    • RE: I fixed this problem finally...    [ Reply ]
    • RE: I fixed this problem finally...    [ Reply ]
  • How to fix problem (Virus Scan)    [ Reply ]
    • RE: How to fix problem (Virus Scan)    [ Reply ]
    • RE: How to fix problem (Virus Scan)    [ Reply ]
  • Another Fix for ASP.NET: Changing userName to "SYSTEM"    [ Reply ]
  • The transport failed to connect to the server. - Only for certain address's.    [ Reply ]
  • error    [ Reply ]
  • The transport lost its connection to the server    [ Reply ]
    • RE: The transport lost its connection to the server    [ Reply ]
  • Errors while moving app Window    [ Reply ]
  • Error: in Sending Mail    [ Reply ]
  • SMTP Mail    [ Reply ]
  • SMTP.Server error -- Specified cast is not valid.    [ Reply ]
  • SMTP.Server error -- Specified cast is not valid.    [ Reply ]
    • RE: SMTP.Server error -- Specified cast is not valid.    [ Reply ]
  • Check for NAT!    [ Reply ]
  • sending e-mail    [ Reply ]
  • Attention: some ISP's block port 25, try 587    [ Reply ]
  • The transport lost its connection to the server.    [ Reply ]
  • dssdfsafs    [ Reply ]
  • Can connect manually, but error persists    [ Reply ]
  • jukermann    [ Reply ]
  • blue    [ Reply ]
  • The transport failed to connect to the server.    [ Reply ]
  • Exchange server    [ Reply ]
  • C# code that worked for me    [ Reply ]
  • Offsite Spam Filtering    [ Reply ]
  • can't send mail    [ Reply ]
  • System.Runtime.InteropServices.COMException: The transport failed to connect to the server.    [ Reply ]
  • The transport failed to connect to the server.    [ Reply ]
  • The transport failed to connect to the server    [ Reply ]
  • cdosys-The transport failed to connect to the server    [ Reply ]
  • transport server error    [ Reply ]
  • CDO Error When Sending Email from VB    [ Reply ]
  • Q&A    [ Reply ]